Geometry
Types for working with geometry.
Classes
Name | Description | |
---|---|---|
Cartographic | A position on the earth defined by longitude, latitude, and height above the WGS84 ellipsoid. | |
CartographicRange | A cartographic range representing a rectangular region if low longitude/latitude > high then area crossing seam is indicated. | |
GeometryStreamBuilder | GeometryStreamBuilder is a helper class for populating the GeometryStreamProps array needed to create a GeometricElement or GeometryPart. | |
GeometryStreamIterator | GeometryStreamIterator is a helper class for iterating a GeometryStreamProps. | |
GeometryStreamIteratorEntry | Holds current state information for GeometryStreamIterator. | |
ImageGraphic | A geometric primitive that displays an image mapped to the corners of a quadrilateral, with an optional border. | Beta |
ImageGraphicCorners | Defines the 4 corners of an ImageGraphic. | Beta |
Placement2d | The placement of a GeometricElement2d. | |
Placement3d | The placement of a GeometricElement3d. | |
TextString | A single line of text, all with the same font, styles (underline, bold, italic), and size. |
Enumerations
Name | Description | |
---|---|---|
GeometryStreamFlags | Flags applied to the entire contents of a GeometryStreamProps. | |
MassPropertiesOperation | Specify whether to accumulate volumes, areas, or lengths for the supplied elements. | Beta |
Interfaces
Name | Description | |
---|---|---|
AreaFillProps | Add a AreaFillProps.gradient, AreaFillProps.backgroundFill, or solid AreaFillProps.color fill to subsequent planar regions (or meshes). | |
DecorationGeometryProps | Information required to request a snap to a pickable decoration from the front end to the back end. | Beta |
GeometryAppearanceProps | Establish a non-default SubCategory or to override SubCategoryAppearance for the geometry that follows. | |
GeometryPartInstanceProps | Add a reference to a GeometryPart from the GeometryStream of a GeometricElement. | |
GeometryStreamEntryProps | Allowed GeometryStream entries - should only set one value. | |
GeometryStreamHeaderProps | An entry in a GeometryStreamProps containing GeometryStreamFlags that apply to the geometry stream as a whole. | |
GeometryStreamIteratorEntry.BRepPrimitive | Represents a BRep within a GeometryStream. | |
GeometryStreamIteratorEntry.GeometryPrimitive | Represents one of a variety of GeometryQuery objects within a GeometryStream. | |
GeometryStreamIteratorEntry.ImagePrimitive | Represents an image within a GeometryStream. | |
GeometryStreamIteratorEntry.PartReference | Represents a reference to a GeometryPart within a GeometryStream. | |
GeometryStreamIteratorEntry.TextStringPrimitive | Represents a text string within a GeometryStream. | |
ImageGraphicProps | JSON representation of an [[ImageGraphic]. | Beta |
LatAndLong | ||
LatLongAndHeight | ||
MassPropertiesRequestProps | Information required to request mass properties for elements from the front end to the back end. | Beta |
MassPropertiesResponseProps | Information returned from the back end to the front end holding the result of the mass properties calculation. | Beta |
MaterialProps | Override SubCategoryAppearance.materialId for subsequent surface and solid geometry. | |
SnapRequestProps | Information required to request a snap to an element from the front end to the back end. | Beta |
SnapResponseProps | Information returned from the back end to the front end holding the result of a snap operation. | Beta |
TextStringProps | Properties for a TextString class. |
Namespaces
Name | Description | |
---|---|---|
BRepEntity | Beta |
Type Aliases
Name | Description | |
---|---|---|
AxisAlignedBox3d | A Range3d that is aligned with the axes of spatial coordinates. | |
AxisAlignedBox3dProps | The properties of a Range3d. | |
ElementAlignedBox2d | A bounding box aligned to the orientation of a 2d Element | |
ElementAlignedBox3d | A bounding box aligned to the orientation of a 3d Element | |
GeometryStreamIteratorEntry.Primitive | Union of all possible geometric primitive types that may appear within a GeometryStream. | |
GeometryStreamProps | A GeometricElement's GeometryStream is represented by an array of GeometryStreamEntryProps. | |
ImageGraphicCornersProps | JSON representation of the 4 corners of an ImageGraphicProps. | Beta |
LocalAlignedBox3d | A bounding box aligned to a local coordinate system |
Last Updated: 13 June, 2024