sortFields Method
Sorts an array of fields with respect to favorite property order. Non-favorited fields get sorted by their default priority and always have lower priority than favorited fields.
sortFields(imodel: IModelConnection, fields: Field[]): Field[]
note initializeConnection
must be called with the imodel
before calling this function.
Parameter | Type | Description |
---|---|---|
imodel | IModelConnection | IModelConnection. |
fields | Field[] | Array of Field's that needs to be sorted. |
Returns - Field[]
Defined in
- presentation/frontend/src/presentation-frontend/favorite-properties/FavoritePropertiesManager.ts Line 317
Last Updated: 30 November, 2023