remove Method

Removes favorite properties from a scope specified and all the more general scopes.

remove(field: Field, imodel: IModelConnection, scope: FavoritePropertiesScope): Promise<void>

note initializeConnection must be called with the imodel before calling this function.

Parameter Type Description
field Field Field that contains properties. If field contains multiple properties, all of them will be un-favorited.
imodel IModelConnection IModelConnection.
scope FavoritePropertiesScope FavoritePropertiesScope to remove the favorite properties from. It also removes from more general scopes.

Returns - Promise<void>

Defined in

Last Updated: 30 November, 2023