has Method
Check if field contains at least one favorite property.
has(field: Field, imodel: IModelConnection, scope: FavoritePropertiesScope): boolean
note initializeConnection
must be called with the imodel
before calling this function.
Parameter | Type | Description |
---|---|---|
field | Field | Field that contains properties. |
imodel | IModelConnection | IModelConnection. |
scope | FavoritePropertiesScope | FavoritePropertiesScope to check for favorite properties. It also checks the more general scopes. |
Returns - boolean
Defined in
- presentation/frontend/src/presentation-frontend/favorite-properties/FavoritePropertiesManager.ts Line 299
Last Updated: 30 November, 2023