changeFieldPriority Method
Changes field properties priorities to lower than another fields priority
changeFieldPriority(imodel: IModelConnection, field: Field, afterField: undefined | Field, visibleFields: Field[]): Promise<void>
note initializeConnection
must be called with the imodel
before calling this function.
Parameter | Type | Description |
---|---|---|
imodel | IModelConnection | IModelConnection. |
field | Field | Field that priority is being changed. |
afterField | undefined | Field | Field that goes before the moved field. If undefined the moving field is changed to the highest priority (to the top). |
visibleFields | Field[] | Array of fields to move the field in. |
Returns - Promise<void>
Defined in
- presentation/frontend/src/presentation-frontend/favorite-properties/FavoritePropertiesManager.ts Line 390
Last Updated: 30 November, 2023