PresentationInstanceFilterBuilderProps Interface
Beta
Props for PresentationInstanceFilterBuilder component.
Methods
Name | Description | |
---|---|---|
onInstanceFilterChanged(filter?: PresentationInstanceFilterInfo): void | Callback that is invoked when filter changes. |
Properties
Name | Type | Description | |
---|---|---|---|
descriptor | Descriptor | Descriptor containing properties and classes that should be available for building filter. | |
imodel | IModelConnection | iModel connection to pull data from. | |
initialFilter | undefined | PresentationInstanceFilterInfo | Initial filter that will be show when component is mounted. | |
ruleGroupDepthLimit | undefined | number | Specifies how deep rule groups can be nested. |
Defined in
Last Updated: 30 November, 2023