Core
Common types used all across presentation-components package.
Classes
Name | Description | |
---|---|---|
ContentDataProvider | Base class for all presentation-driven content providers. | |
DataProvidersFactory | A factory class than can be used to create presentation data providers targeted towards | Deprecated |
Global Functions
Name | Description | |
---|---|---|
useRulesetRegistration | Custom hook which registers supplied Ruleset on mount and removes on unmount. |
Interfaces
Name | Description | |
---|---|---|
CacheInvalidationProps | Properties for invalidating content cache. | |
ContentDataProviderProps | Properties for creating a ContentDataProvider instance. |
|
DataProvidersFactoryProps | Data structure holding initialization properties for DataProvidersFactory | Deprecated |
DiagnosticsProps | Settings for capturing diagnostics data. | |
IContentDataProvider | Interface for all presentation-driven content providers. | |
IPresentationDataProvider | Interface for a presentation data provider | |
IUnifiedSelectionComponent | An interface for all unified selection components |
Namespaces
Name | Description | |
---|---|---|
CacheInvalidationProps |
Last Updated: 30 November, 2023