createSimilarInstancesRuleset Method
Create a ruleset with content rules for getting instances are of the
same ECClass and have the same property value as the provided record
.
createSimilarInstancesRuleset(field: Field, record: Item, computeDisplayValue?: ComputeDisplayValueCallback): Promise<{ description: string, ruleset: Ruleset }>
Parameter | Type | Description |
---|---|---|
field | Field | A field identifying which property of the record we should use |
record | Item | A record whose similar instances should be found |
computeDisplayValue | ComputeDisplayValueCallback | Optional callback function to calculate display value that's used in ruleset's description. If not provided, display value from record is used instead. |
Returns - Promise<{ description: string, ruleset: Ruleset }>
Defined in
Last Updated: 30 November, 2023