constructor Method
Constructor
SectionMarkerSet(viewport: ScreenViewport, markers: SectionMarker[]): SectionMarkerSet
note Each marker's SectionDrawingLocationState must be associated with the same IModelConnection as the viewport; any markers from other iModels will be omitted.
Parameter | Type | Description |
---|---|---|
viewport | ScreenViewport | The viewport in which the markers are to be displayed. |
markers | SectionMarker[] | The markers to be displayed. |
Returns - SectionMarkerSet
Defined in
- hypermodeling/src/SectionMarkers.ts Line 177
Last Updated: 30 November, 2023