SectionMarkerConfig Interface
Configures display of SectionMarkers for HyperModelingDecorators.
see HyperModelingDecorator.updateConfiguration or HyperModelingDecorator.replaceConfiguration to change the configuration for a specific decorator.
see HyperModeling.initialize to set the default configuration for all decorators at package initialization.
see HyperModeling.updateConfiguration or HyperModeling.replaceConfiguration to change the default configuration for all subsequently created decorators.
see HyperModelingConfig.
Properties
Name | Type | Description | |
---|---|---|---|
hiddenSectionTypes Readonly | undefined | SectionType[] | A list of types of section markers that shouold not be displayed. | |
ignoreCategorySelector Readonly | undefined | boolean | Whether to hide markers belonging to categories that are not present in the view's CategorySelector. | |
ignoreModelSelector Readonly | undefined | boolean | Whether to hide markers belonging to models that are not present in the view's ModelSelector. |
Defined in
Last Updated: 30 November, 2023