alignToSpatialView Method
Aligns the view to match the frustum of the spatial view associated with the specified marker.
alignToSpatialView(marker: SectionMarker): Promise<boolean>
see HyperModelingDecorator.alignView to align to the section plane, which may differ.
see HyperModelingDecorator.toggleSection to also apply the clip volume.
Parameter | Type | Description |
---|---|---|
marker | SectionMarker | The marker whose spatial view's frustum should be applied. |
Returns - Promise<boolean>
false if the frustum could not be applied, e.g. because the spatial view could not be loaded or the viewport is viewing a 2d model.
Defined in
Last Updated: 30 November, 2023