parseToggle Function
Beta
Parses a string case-insensitively returning true for "ON", false for "OFF" undefined for "TOGGLE" or undefined, and the input string for anything else Used by various tools which take such arguments.
parseToggle(arg: undefined | string): string | boolean | undefined
Parameter | Type | Description |
---|---|---|
arg | undefined | string |
Returns - string | boolean | undefined
Defined in
Last Updated: 30 November, 2023