constructor Method
Initializes a new SchemaItemDiagnostic.
SchemaItemDiagnostic<TYPE extends SchemaItem<TYPE>, ARGS extends any[]>(ecDefinition: SchemaItem, messageArgs: ARGS, category: DiagnosticCategory = DiagnosticCategory.Error): SchemaItemDiagnostic<TYPE, ARGS>
Parameter | Type | Description |
---|---|---|
ecDefinition | SchemaItem | The EC object to associate with the diagnostic. |
ARGS | The arguments used when formatting the diagnostic message. | |
category | DiagnosticCategory | The DiagnosticCategory to associate with the diagnostic, Error by default. |
Returns - SchemaItemDiagnostic<TYPE, ARGS>
Defined in
Last Updated: 30 November, 2023