constructor Method
Initializes a new RelationshipConstraintDiagnostic.
RelationshipConstraintDiagnostic<ARGS extends any[]>(constraint: RelationshipConstraint, messageArgs: ARGS, category: DiagnosticCategory = DiagnosticCategory.Error): RelationshipConstraintDiagnostic<ARGS>
Parameter | Type | Description |
---|---|---|
constraint | RelationshipConstraint | The Relationship Constraint to associate with the diagnostic. |
ARGS | The arguments used when formatting the diagnostic message. | |
category | DiagnosticCategory | The DiagnosticCategory to associate with the diagnostic, Error by default. |
Returns - RelationshipConstraintDiagnostic<ARGS>
Defined in
Last Updated: 30 November, 2023