constructor Method
Initializes a new FormatDiagnosticReporter
FormatDiagnosticReporter(suppressions?: Map<string, string[]>, localization?: Localization): FormatDiagnosticReporter
Parameter | Type | Description |
---|---|---|
suppressions | Map<string, string[]> | A Map where the key is a schema full name and the value is collection of diagnostic codes to suppress. |
localization | Localization | The Localization instance to use to translate validation messages. |
Returns - FormatDiagnosticReporter
Defined in
Last Updated: 30 November, 2023