constructor Method
Initializes a new BaseDiagnostic.
BaseDiagnostic<TYPE extends AnyECType, ARGS extends any[]>(ecDefinition: TYPE, messageArgs?: ARGS, category: DiagnosticCategory = DiagnosticCategory.Error): BaseDiagnostic<TYPE, ARGS>
Parameter | Type | Description |
---|---|---|
ecDefinition | TYPE | The EC object to associate with the diagnostic. |
ARGS | The arguments used when formatting the diagnostic message. | |
category | DiagnosticCategory | The DiagnosticCategory to associate with the diagnostic, Error by default. |
Returns - BaseDiagnostic<TYPE, ARGS>
Defined in
Last Updated: 30 November, 2023