computeInCircleDeterminantIsStrongPositive MethodStatic
- nodeA is a given node
- nodeA1 is its nodeA.faceSuccessor
- nodeA2 is nodeA1.faceSuccessor, i.e. 3rd node of triangle A
- nodeB is nodeA.edgeMate, i.e. a node in the "other" triangle at nodeA's edge
- nodeB1 is nodeB.faceSuccessor
- nodeB2 is nodeB1.faceSuccessor, i.e the 3rd node of triangle B Construct (as simple doubles, to avoid object creation) xy vectors from:
- (ux,uy): nodeA to nodeA1, i.e. the shared edge
- (vx,vy): nodeA to nodeA2,
- (wx,wy): nodeA to nodeB2
- this determinant is positive if nodeA is "in the circle" of nodeB2, nodeA1, nodeA2
- Return true if clearly positive
- Return false if clearly negative or almost zero.
computeInCircleDeterminantIsStrongPositive(nodeA: ): boolean
Parameter | Type | Description |
---|---|---|
nodeA | node on the diagonal edge of candidate for edge flip. |
Returns - boolean
Defined in
- topology/Triangulation.ts Line 80
Last Updated: 30 November, 2023