setSearchRay Method
Set (replace contents) ray with
origin
at startdirection
is unit vector from start towards targeta
is distance from start to target.
setSearchRay(start: HalfEdgePositionDetail, target: Point3d, ray: Ray3d): boolean
Parameter | Type | Description |
---|---|---|
start | HalfEdgePositionDetail | existing position |
target | Point3d | target xy coordinates |
ray | Ray3d | ray to update |
Returns - boolean
Defined in
Last Updated: 30 November, 2023