collectExtendedBoundaryLoopFromSeed MethodStatic
Announce nodes that are "extended face boundary" by conditions (usually mask of node and mate) in test functions.
- After each node, the next candidate in reached by looking "around the head vertex loop" for the next boundary.
- "Around the vertex" from nodeA means
- First look at nodeA.faceSuccessor;
- Then look at vertexPredecessor around that vertex loop.
- "Around the vertex" from nodeA means
- Each accepted node is passed to announceNode, and marked with the visit mask.
- The counter of the announceEdge function is zero for the first edge, then increases with each edge.
collectExtendedBoundaryLoopFromSeed(seed: , visitMask: , isBoundaryEdge: , announceEdge: (edge: , counter: number) => void): void
Parameter | Type | Description |
---|---|---|
seed | start node. | |
visitMask | ||
isBoundaryEdge | ||
announceEdge | (edge: , counter: number) => void |
Returns - void
Defined in
- topology/HalfEdgeGraphSearch.ts Line 264
Last Updated: 30 November, 2023