strokeConstantVSection Method
return strokes for a cross-section (elliptic arc) at specified fraction v along the axis.
- fixedStrokeCount takes priority over stroke options.
- The linestring is created by LineString3d.createForStrokes (fixedStrokeCount, options), which sets up property according to the options:
- optional fractions member
- optional uvParams. uvParams are installed as full-scale distance parameters.
- optional derivatives.
strokeConstantVSection(v: number, fixedStrokeCount: undefined | number, options: undefined | StrokeOptions): LineString3d
Parameter | Type | Description |
---|---|---|
v | number | fractional position along the cone axis |
fixedStrokeCount | undefined | number | optional stroke count. |
options | undefined | StrokeOptions | optional stroke options. |
Returns - LineString3d
Defined in
- solid/Cone.ts Line 154
Last Updated: 30 November, 2023