createAxisPoints MethodStatic
create a cylinder or cone from two endpoints and their radii. The circular cross sections are perpendicular to the axis line from start to end point.
- both radii must be of the same sign.
- negative radius is accepted to create interior surface. Downstream effects of that combined with capping may be a problem.
createAxisPoints(centerA: Point3d, centerB: Point3d, radiusA: number, radiusB: number, capped: boolean): undefined | Cone
Parameter | Type | Description |
---|---|---|
centerA | Point3d | |
centerB | Point3d | |
radiusA | number | |
radiusB | number | |
capped | boolean |
Returns - undefined | Cone
Defined in
- solid/Cone.ts Line 84
Last Updated: 30 November, 2023