partitionFacetIndicesByEdgeConnectedComponent MethodStatic
Partition the facet set into connected components. Each facet in a given component shares an edge only with other facets in the component (or is a boundary edge).
partitionFacetIndicesByEdgeConnectedComponent(polyface: Polyface | PolyfaceVisitor, stopAtVisibleEdges: boolean = false): number[][]
Parameter | Type | Description |
---|---|---|
polyface | Polyface | PolyfaceVisitor | facets to partition |
stopAtVisibleEdges | boolean | whether to further split connected components by visible edges of the polyface |
Returns - number[][]
collection of facet index arrays, one per connected component
Defined in
- polyface/PolyfaceQuery.ts Line 851
Last Updated: 30 November, 2023