isPolyfaceManifold MethodStatic
Test edges pairing in source
mesh.
- for
allowSimpleBoundaries === false
true return means this is a closed 2-manifold surface - for
allowSimpleBoundaries === true
true means this is a 2-manifold surface which may have boundary, but is still properly matched internally. - Any edge with 3 or more incident facets triggers
false
return. - Any edge with 2 incident facets in the same direction triggers a
false
return.
isPolyfaceManifold(source: Polyface, allowSimpleBoundaries: boolean = false): boolean
Parameter | Type | Description |
---|---|---|
source | Polyface | |
allowSimpleBoundaries | boolean |
Returns - boolean
Defined in
- polyface/PolyfaceQuery.ts Line 371
Last Updated: 30 November, 2023