isConvexByDihedralAngleCount MethodStatic
Test for convex volume by dihedral angle tests on all edges.
- This tests if all dihedral angles are positive.
- In a closed solid, this is a strong test for overall convexity.
- With
ignoreBoundaries
true, this may be a useful test when all the facets are in a single edge-connected component, such as a pyramid with no underside. - It is not a correct test if there are multiple, disjoint components.
- Take the above-mentioned pyramid with no underside.
- Within the same mesh, have a second pyramid placed to the side, still facing upward.
- The angles will pass the dihedral convexity test, but the composite thing surely is not convex.
isConvexByDihedralAngleCount(source: Polyface, ignoreBoundaries: boolean = false): boolean
Parameter | Type | Description |
---|---|---|
source | Polyface | mesh to examine |
ignoreBoundaries | boolean | if true, ignore simple boundary edges, i.e. allow unclosed meshes. |
Returns - boolean
true if the mesh is closed and has all dihedral angles (angle across edge) positive
Defined in
- polyface/PolyfaceQuery.ts Line 291
Last Updated: 30 November, 2023