dihedralAngleSummary MethodStatic
Compute a number summarizing the dihedral angles in the mesh.
dihedralAngleSummary(source: Polyface, ignoreBoundaries: boolean = false): number
see PolyfaceQuery.isConvexByDihedralAngleCount for comments about ignoreBoundaries===true when there are multiple connected components.
Parameter | Type | Description |
---|---|---|
source | Polyface | mesh to examine |
ignoreBoundaries | boolean | if true, ignore simple boundary edges, i.e. allow unclosed meshes. |
Returns - number
a number summarizing the dihedral angles in the mesh.
- Return 1 if all angles are positive or planar. The mesh is probably convex with outward normals.
- Return -1 if all angles are negative or planar. The mesh is probably convex with inward normals.
- Return 0 if
- angles area mixed
- any edge has other than 1 incident facet or more than 2 incident facets.
- (but null edges are permitted -- These occur naturally at edges of quads at north or south pole)
Defined in
- polyface/PolyfaceQuery.ts Line 308
Last Updated: 30 November, 2023