computeFacetUnitNormal MethodStatic
Try to compute a unit normal for a facet accessible through a visitor.
- Unit normal is computed by
PolygonOps.unitNormal
with the points around the facet.
computeFacetUnitNormal(visitor: PolyfaceVisitor, facetIndex: number, result?: Vector3d): undefined | Vector3d
Parameter | Type | Description |
---|---|---|
visitor | PolyfaceVisitor | |
facetIndex | number | |
result | Vector3d |
Returns - undefined | Vector3d
Defined in
- polyface/PolyfaceQuery.ts Line 1302
Last Updated: 30 November, 2023