buildAverageNormals MethodStatic
- At each vertex of the mesh
- Find clusters of almost parallel normals
- Compute simple average of those normals
- Index to the averages
- For typical meshes, this correctly clusters adjacent normals.
- One can imagine a vertex with multiple "smooth cone-like" sets of incident facets such that averaging occurs among two nonadjacent cones. But this does not seem to be a problem in practice.
buildAverageNormals(polyface: IndexedPolyface, toleranceAngle: Angle = ...): void
Parameter | Type | Description |
---|---|---|
polyface | IndexedPolyface | polyface to update. |
toleranceAngle | Angle | averaging is done between normals up to this angle. |
Returns - void
Defined in
- polyface/PolyfaceQuery.ts Line 1349
Last Updated: 30 November, 2023