boundaryOfVisibleSubset MethodStatic
Return the boundary of facets that are facing the eye.
boundaryOfVisibleSubset(polyface: IndexedPolyface, visibilitySelect: | "1" | "2", vectorToEye: Vector3d, sideAngleTolerance: Angle = ...): undefined | CurveCollection
Parameter | Type | Description |
---|---|---|
polyface | IndexedPolyface | |
visibilitySelect | | "1" | "2" | |
vectorToEye | Vector3d | |
sideAngleTolerance | Angle |
Returns - undefined | CurveCollection
Defined in
- polyface/PolyfaceQuery.ts Line 600
Last Updated: 30 November, 2023