boundaryEdges MethodStatic
construct a CurveCollection containing boundary edges.
- each edge is a LineSegment3d
boundaryEdges(source: undefined | Polyface | PolyfaceVisitor, includeDanglers: boolean = true, includeMismatch: boolean = true, includeNull: boolean = true): undefined | CurveCollection
Parameter | Type | Description |
---|---|---|
source | undefined | Polyface | PolyfaceVisitor | polyface or visitor |
includeDanglers | boolean | true to in include typical boundary edges with a single incident facet |
includeMismatch | boolean | true to include edges with more than 2 incident facets |
includeNull | boolean | true to include edges with identical start and end vertex indices. |
Returns - undefined | CurveCollection
Defined in
- polyface/PolyfaceQuery.ts Line 394
Last Updated: 30 November, 2023