announceSweepLinestringToConvexPolyfaceXY MethodStatic
Find segments (within the linestring) which project to facets.
- Announce each pair of linestring segment and on-facet segment through a callback.
- Facets are ASSUMED to be convex and planar.
announceSweepLinestringToConvexPolyfaceXY(linestringPoints: GrowableXYZArray, polyface: Polyface, announce: AnnounceDrapePanel): any
Parameter | Type | Description |
---|---|---|
linestringPoints | GrowableXYZArray | |
polyface | Polyface | |
announce | AnnounceDrapePanel |
Returns - any
Defined in
- polyface/PolyfaceQuery.ts Line 459
Last Updated: 30 November, 2023