announceBoundaryChainsAsLineString3d MethodStatic
Search for edges with only 1 incident facet.
- chain them into loops
- emit the loops to the announceLoop function
announceBoundaryChainsAsLineString3d(mesh: Polyface | PolyfaceVisitor, announceLoop: (points: LineString3d) => void): void
Parameter | Type | Description |
---|---|---|
mesh | Polyface | PolyfaceVisitor | |
announceLoop | (points: LineString3d) => void |
Returns - void
Defined in
- polyface/PolyfaceQuery.ts Line 613
Last Updated: 30 November, 2023