reverseIndices Method
reverse indices facet-by-facet, with the given facetStartIndex array delimiting faces.
- facetStartIndex[0] == 0 always -- start of facet zero.
- facet k has indices from facetStartIndex[k] <= i < facetStartIndex[k+1]
- hence for "internal" k, facetStartIndex[k] is both the upper limit of facet k-1 and the start of facet k.
reverseIndices(facetStartIndex?: number[]): void
Parameter | Type | Description |
---|---|---|
facetStartIndex | number[] |
Returns - void
Defined in
- polyface/PolyfaceData.ts Line 354
Last Updated: 30 November, 2023