isValidFacetStartIndexArray MethodStatic
Test if facetStartIndex is (minimally!) valid:
- length must be nonzero (recall that for "no facets" the facetStartIndexArray still must contain a 0)
- Each entry must be strictly smaller than the one that follows.
isValidFacetStartIndexArray(facetStartIndex: number[]): boolean
Parameter | Type | Description |
---|---|---|
facetStartIndex | number[] | array of facetStart data. facet i has indices at facetsStartIndex[i] to (one before) facetStartIndex[i+1] |
Returns - boolean
Defined in
- polyface/PolyfaceData.ts Line 437
Last Updated: 30 November, 2023