computeCutFill MethodStatic
- Split facets into vertically overlapping sections
- both meshes are represented by visitors rather than the meshes themselves
- If the data in-hand is a mesh, call with
mesh.createVisitor
- If the data in-hand is a mesh, call with
- The respective clip parts are returned as separate meshes.
- Caller may set either or both builders to toggle facet order (e.g. toggle the lower facets to make them "point down" in cut-fill application)
- Both polyfaces are assumed convex with CCW orientation viewed from above.
- Each output contains some facets from meshA and some from meshB:
- meshAUnderB -- areas where meshA is underneath mesh B.
- If A is "design surface" and B is existing DTM, this is "cut" volume
- meshAOverB -- areas where meshB is over meshB.
- If A is "design surface" and B is existing DTM, this is "fill" volume
- meshAUnderB -- areas where meshA is underneath mesh B.
computeCutFill(meshA: IndexedPolyface, meshB: IndexedPolyface): { meshAOverB: IndexedPolyface, meshAUnderB: IndexedPolyface }
Parameter | Type | Description |
---|---|---|
meshA | IndexedPolyface | |
meshB | IndexedPolyface |
Returns - { meshAOverB: IndexedPolyface, meshAUnderB: IndexedPolyface }
Defined in
- polyface/PolyfaceClip.ts Line 573
Last Updated: 30 November, 2023