clipPolyface MethodStatic
Clip each facet of polyface to the ClipPlane or ConvexClipPlaneSet
- This method parses the variant input types and calls a more specific method.
- To get both inside and outside parts, use clipPolyfaceInsideOutside
- WARNING: The new mesh is "points only".
clipPolyface(polyface: Polyface, clipper: ConvexClipPlaneSet | ClipPlane): undefined | Polyface
Parameter | Type | Description |
---|---|---|
polyface | Polyface | |
clipper | ConvexClipPlaneSet | ClipPlane |
Returns - undefined | Polyface
Defined in
- polyface/PolyfaceClip.ts Line 457
Last Updated: 30 November, 2023