clipPolyfaceClipPlaneWithClosureFace MethodStatic
Clip each facet of polyface to the ClipPlane.
- Return all surviving clip as a new mesh.
- WARNING: The new mesh is "points only" -- parameters, normals, etc are not interpolated
clipPolyfaceClipPlaneWithClosureFace(polyface: Polyface, clipper: ClipPlane, insideClip: boolean = true, buildClosureFaces: boolean = true): Polyface
Parameter | Type | Description |
---|---|---|
polyface | Polyface | |
clipper | ClipPlane | |
insideClip | boolean | |
buildClosureFaces | boolean |
Returns - Polyface
Defined in
- polyface/PolyfaceClip.ts Line 97
Last Updated: 30 November, 2023