addMiteredPipes Method
- Create (and add to the builder) quad facets for a mitered pipe that follows a centerline curve.
- Circular or elliptical pipe cross sections can be specified by supplying either a radius, a pair of semi-axis lengths, or a full Arc3d.
- For semi-axis length input, x corresponds to an ellipse local axis nominally situated parallel to the xy-plane.
- The center of Arc3d input is translated to the centerline start point to act as initial cross section.
addMiteredPipes(centerline: Point3d[] | CurvePrimitive | IndexedXYZCollection, sectionData: number | Arc3d | Readonly<WritableXAndY>, numFacetAround: number = 12): void
Parameter | Type | Description |
---|---|---|
centerline | Point3d[] | CurvePrimitive | IndexedXYZCollection | centerline of pipe. If curved, it will be stroked using the builder's StrokeOptions. |
sectionData | number | Arc3d | Readonly<WritableXAndY> | circle radius, ellipse semi-axis lengths, or full Arc3d |
numFacetAround | number | how many equal parameter-space chords around each section |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 1834
Last Updated: 30 November, 2023