addLinearSweepLineStringsXYZOnly Method
Add point data (no params, normals) for linestrings.
- This recurses through curve chains (loops and paths)
- linestrings are swept
- All other curve types are ignored.
addLinearSweepLineStringsXYZOnly(contour: AnyCurve, vector: Vector3d): void
Parameter | Type | Description |
---|---|---|
contour | AnyCurve | contour which contains only linestrings |
vector | Vector3d | sweep vector |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 1049
Last Updated: 30 November, 2023