addFacetFromGrowableArrays Method
Add a polygon to the evolving facets.
- Add points to the polyface
- indices are added (in reverse order if indicated by the builder state)
addFacetFromGrowableArrays(points: GrowableXYZArray, normals: undefined | GrowableXYZArray, params: undefined | GrowableXYArray, colors: undefined | number[], edgeVisible?: boolean[]): void
Parameter | Type | Description |
---|---|---|
points | GrowableXYZArray | |
normals | undefined | GrowableXYZArray | array of points. This may contain extra points not to be used in the polygon |
params | undefined | GrowableXYArray | |
colors | undefined | number[] | |
edgeVisible | boolean[] |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 1431
Last Updated: 30 November, 2023