tryTransformInPlace Method
Apply transform
to the data in each channel.
tryTransformInPlace(transform: Transform): boolean
see AuxChannelDataType for details regarding how each data type is affected by the transform.
note This method may fail if a channel of AuxChannelDataType.Normal exists and transform.matrix
is non-invertible.
Parameter | Type | Description |
---|---|---|
transform | Transform |
Returns - boolean
true if the channels were all successfully transformed.
Defined in
- polyface/AuxData.ts Line 240
Last Updated: 30 November, 2023