create MethodStatic
Create a visitor for iterating the facets of polyface
, with indicated number of points to be added to each facet to produce closed point arrays
Typical wrap counts are:
- 0 -- leave the point arrays with "missing final edge"
- 1 -- add point 0 as closure point
- 2 -- add points 0 and 1 as closure and wrap point. This is useful when vertex visit requires two adjacent vectors, e.g. for cross products.
create(polyface: IndexedPolyface, numWrap: number): IndexedPolyfaceVisitor
Parameter | Type | Description |
---|---|---|
polyface | IndexedPolyface | |
numWrap | number |
Returns - IndexedPolyfaceVisitor
Defined in
Last Updated: 30 November, 2023