getParam Method

Get uv parameter interpolated from facet data.

getParam(facetParams?: IndexedXYCollection, facetVertices?: IndexedXYZCollection, distanceTolerance: number = Geometry.smallMetricDistance): undefined | Point2d

Parameter Type Description
facetParams IndexedXYCollection used to compute the uv parameter cache
facetVertices IndexedXYZCollection used to compute the barycentric coordinate cache
distanceTolerance number used to compute the barycentric coordinate cache

Returns - undefined | Point2d

reference to cached uv parameter

Defined in

Last Updated: 30 November, 2023