getNormal Method
Get normal interpolated from facet data.
getNormal(facetNormals?: IndexedXYZCollection, facetVertices?: IndexedXYZCollection, distanceTolerance: number = Geometry.smallMetricDistance): undefined | Vector3d
Parameter | Type | Description |
---|---|---|
facetNormals | IndexedXYZCollection | used to compute the normal cache |
facetVertices | IndexedXYZCollection | used to compute the barycentric coordinate cache |
distanceTolerance | number | used to compute the barycentric coordinate cache |
Returns - undefined | Vector3d
reference to cached normal
Defined in
- polyface/FacetLocationDetail.ts Line 398
Last Updated: 30 November, 2023