getBarycentricCoordinates Method
Get the barycentric coordinates of this location, if they have been computed.
getBarycentricCoordinates(facetVertices?: IndexedXYZCollection, distanceTolerance: number = Geometry.smallMetricDistance): undefined | number[]
Parameter | Type | Description |
---|---|---|
facetVertices | IndexedXYZCollection | used to compute the barycentric coordinate cache |
distanceTolerance | number | used to compute the barycentric coordinate cache |
Returns - undefined | number[]
cached barycentric coordinates
Defined in
- polyface/FacetLocationDetail.ts Line 443
Last Updated: 30 November, 2023