lineSegment3dXYTransverseIntersectionUnbounded MethodStatic
Return true if lines (a0,a1) to (b0, b1) have a simple intersection using only xy parts Return the fractional (not xy) coordinates in result.x, result.y
lineSegment3dXYTransverseIntersectionUnbounded(a0: Point3d, a1: Point3d, b0: Point3d, b1: Point3d, result: Vector2d): boolean
Parameter | Type | Description |
---|---|---|
a0 | Point3d | start point of line a |
a1 | Point3d | end point of line a |
b0 | Point3d | start point of line b |
b1 | Point3d | end point of line b |
result | Vector2d | point to receive fractional coordinates of intersection. result.x is fraction on line a. result.y is fraction on line b. |
Returns - boolean
Defined in
- numerics/Polynomials.ts Line 1451
Last Updated: 30 November, 2023