lineSegment3dHXYTransverseIntersectionUnbounded MethodStatic
Return true if lines (a0,a1) to (b0, b1) have a simple intersection using only xy parts of WEIGHTED 4D Points Return the fractional (not xy) coordinates in result.x, result.y
lineSegment3dHXYTransverseIntersectionUnbounded(hA0: Point4d, hA1: Point4d, hB0: Point4d, hB1: Point4d, result?: Vector2d): undefined | Vector2d
Parameter | Type | Description |
---|---|---|
hA0 | Point4d | homogeneous start point of line a |
hA1 | Point4d | homogeneous end point of line a |
hB0 | Point4d | homogeneous start point of line b |
hB1 | Point4d | homogeneous end point of line b |
result | Vector2d | point to receive fractional coordinates of intersection. result.x is fraction on line a. result.y is fraction on line b. |
Returns - undefined | Vector2d
Defined in
- numerics/Polynomials.ts Line 1484
Last Updated: 30 November, 2023