areEquivalentPrincipalAxes MethodStatic
Test for match among selected members as they exist after inertiaProductsToPrincipalAxes
- The members considered are
- origin of local to world map (i.e. centroid)
- radius of gyration
- axes of localToWorldMap.
- Axis direction tests allow these quirks:
- opposite orientation is considered matched.
- Full xyz symmetry: If x,y,z radii are matched, axes are not tested.
- Symmetry in xy plane: If x and y radii are matched, the x and y axes area allowed to spin freely. Only Z direction is tested.
- If either or both are undefined, returns false.
areEquivalentPrincipalAxes(dataA: undefined | MomentData, dataB: undefined | MomentData): boolean
Parameter | Type | Description |
---|---|---|
dataA | undefined | MomentData | first set of moments |
dataB | undefined | MomentData | second set of moments |
Returns - boolean
Defined in
- geometry4d/MomentData.ts Line 221
Last Updated: 30 November, 2023