accumulateTriangleToLineStringMomentsXY Method
compute moments of triangles from a base point to the given linestring. Accumulate them to this.sums.
- If
pointA
is undefined, usethis.origin
as pointA. - If
this.needOrigin
is set, the first point of the array is captured as local origin for subsequent sums.
accumulateTriangleToLineStringMomentsXY(sweepBase: undefined | Readonly<WritableXAndY>, points: GrowableXYZArray): void
Parameter | Type | Description |
---|---|---|
sweepBase | undefined | Readonly<WritableXAndY> | |
points | GrowableXYZArray |
Returns - void
Defined in
- geometry4d/MomentData.ts Line 365
Last Updated: 30 November, 2023