accumulateTriangleMomentsXY Method
compute moments of a triangle from the origin to the given line. Accumulate them to this.sums.
- If
pointA
is undefined, usethis.origin
as pointA. - If
this.needOrigin
is set, pointB is used
accumulateTriangleMomentsXY(pointA: undefined | Readonly<WritableXAndY>, pointB: Readonly<WritableXAndY>, pointC: Readonly<WritableXAndY>): void
Parameter | Type | Description |
---|---|---|
pointA | undefined | Readonly<WritableXAndY> | |
pointB | Readonly<WritableXAndY> | |
pointC | Readonly<WritableXAndY> |
Returns - void
Defined in
- geometry4d/MomentData.ts Line 302
Last Updated: 30 November, 2023