applySummed01Limits Method
walk the maps in the array.
- in maps with no component data
- increment map.a0 and map.a1 by the incoming distance a0
- in maps with component data:
- recurse through the component array.
- increment map.a0 by the incoming a0.
- returned a1 from the componentData array becomes a1
applySummed01Limits(incomingSum: number): number
Parameter | Type | Description |
---|---|---|
incomingSum | number | lower value to add to a0 for first map. |
Returns - number
upper value of a1 in final map.
Defined in
- curve/Query/StrokeCountChain.ts Line 232
Last Updated: 30 November, 2023